	<!doctype html>
<!--[if lt IE 7]><html class="no-js ie ie6 lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]-->
<!--[if IE 7]><html class="no-js ie ie7 lt-ie9 lt-ie8" lang="en-US"> <![endif]-->
<!--[if IE 8]><html class="no-js ie ie8 lt-ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--><html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
    <!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-P5PNM3N');</script>
<!-- End Google Tag Manager -->
        <title>Building Payment Microservice in Starcity - Flexiana</title>
    <link rel="stylesheet" href="https://flexiana.com/app/themes/flexianacom/style.css" type="text/css" media="screen" />
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="apple-touch-icon" sizes="180x180" href="https://flexiana.com/app/themes/flexianacom/dist/assets/favicon/apple-touch-icon.png">
    <link rel="icon" type="image/png" sizes="32x32" href="https://flexiana.com/app/themes/flexianacom/dist/assets/favicon/favicon-32x32.png">
    <link rel="icon" type="image/png" sizes="16x16" href="https://flexiana.com/app/themes/flexianacom/dist/assets/favicon/favicon-16x16.png">
    <link rel="manifest" href="https://flexiana.com/app/themes/flexianacom/dist/assets/favicon/site.webmanifest">
    <link rel="mask-icon" href="https://flexiana.com/app/themes/flexianacom/dist/assets/favicon/safari-pinned-tab.svg">
    <meta name="msapplication-TileColor" content="#333">
    <meta name="theme-color" content="#333">
    <!-- Google Analytics -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-80055034-1', 'auto');
ga('send', 'pageview');
</script>
<!-- End Google Analytics -->
    <!-- smartlook.com -->
<script type='text/javascript'>
  window.smartlook||(function(d) {
    var o=smartlook=function(){ o.api.push(arguments)},h=d.getElementsByTagName('head')[0];
    var c=d.createElement('script');o.api=new Array();c.async=true;c.type='text/javascript';
    c.charset='utf-8';c.src='https://rec.smartlook.com/recorder.js';h.appendChild(c);
    })(document);
    smartlook('init', '73b13f30ecdc1c6de3ad8a025c79c5e4b9797f7b');
</script>
<!-- End smartlook.com -->
    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<meta name="description" content="Starcity needed to build a stable, complex application to manage their business processes that is ready for the fast growth of the company." />
	<link rel="canonical" href="https://flexiana.com/2020/01/building-payment-microservice" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Building Payment Microservice in Starcity - Flexiana" />
	<meta property="og:description" content="Starcity needed to build a stable, complex application to manage their business processes that is ready for the fast growth of the company." />
	<meta property="og:url" content="https://flexiana.com/2020/01/building-payment-microservice" />
	<meta property="og:site_name" content="Flexiana" />
	<meta property="article:publisher" content="https://www.facebook.com/FlexianaDevGroup/" />
	<meta property="article:published_time" content="2020-01-29T12:04:48+00:00" />
	<meta property="article:modified_time" content="2020-07-30T16:18:44+00:00" />
	<meta property="og:image" content="https://flexiana.com/app/uploads/2020/01/PPC_Flexiana_1-scaled.jpg" />
	<meta property="og:image:width" content="2560" />
	<meta property="og:image:height" content="1340" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@flexiana" />
	<meta name="twitter:site" content="@flexiana" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Pawel Zielonka" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="7 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://flexiana.com/#organization","name":"Flexiana, LLC","url":"https://flexiana.com/","sameAs":["https://www.facebook.com/FlexianaDevGroup/","https://www.instagram.com/flexiana.team/","https://www.linkedin.com/company/flexiana/","https://www.youtube.com/channel/UCg61aY2i6xcJl0KVNqX51Dg","https://twitter.com/flexiana"],"logo":{"@type":"ImageObject","@id":"https://flexiana.com/#logo","inLanguage":"en-US","url":"https://flexiana.com/app/uploads/2020/06/logo-flexiana.png","contentUrl":"https://flexiana.com/app/uploads/2020/06/logo-flexiana.png","width":1600,"height":334,"caption":"Flexiana, LLC"},"image":{"@id":"https://flexiana.com/#logo"}},{"@type":"WebSite","@id":"https://flexiana.com/#website","url":"https://flexiana.com/","name":"Flexiana","description":"","publisher":{"@id":"https://flexiana.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://flexiana.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://flexiana.com/2020/01/building-payment-microservice#primaryimage","inLanguage":"en-US","url":"https://flexiana.com/app/uploads/2020/01/PPC_Flexiana_1-scaled.jpg","contentUrl":"https://flexiana.com/app/uploads/2020/01/PPC_Flexiana_1-scaled.jpg","width":2560,"height":1340,"caption":"Screenshot of software development"},{"@type":"WebPage","@id":"https://flexiana.com/2020/01/building-payment-microservice#webpage","url":"https://flexiana.com/2020/01/building-payment-microservice","name":"Building Payment Microservice in Starcity - Flexiana","isPartOf":{"@id":"https://flexiana.com/#website"},"primaryImageOfPage":{"@id":"https://flexiana.com/2020/01/building-payment-microservice#primaryimage"},"datePublished":"2020-01-29T12:04:48+00:00","dateModified":"2020-07-30T16:18:44+00:00","description":"Starcity needed to build a stable, complex application to manage their business processes that is ready for the fast growth of the company.","breadcrumb":{"@id":"https://flexiana.com/2020/01/building-payment-microservice#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://flexiana.com/2020/01/building-payment-microservice"]}]},{"@type":"BreadcrumbList","@id":"https://flexiana.com/2020/01/building-payment-microservice#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://flexiana.com/"},{"@type":"ListItem","position":2,"name":"News","item":"https://flexiana.com/news"},{"@type":"ListItem","position":3,"name":"Case studies","item":"https://flexiana.com/news/case-studies"},{"@type":"ListItem","position":4,"name":"Building Payment Microservice in Starcity"}]},{"@type":"Article","@id":"https://flexiana.com/2020/01/building-payment-microservice#article","isPartOf":{"@id":"https://flexiana.com/2020/01/building-payment-microservice#webpage"},"author":{"@id":"https://flexiana.com/#/schema/person/94036a92c687499a03b07818de7bbe1d"},"headline":"Building Payment Microservice in Starcity","datePublished":"2020-01-29T12:04:48+00:00","dateModified":"2020-07-30T16:18:44+00:00","mainEntityOfPage":{"@id":"https://flexiana.com/2020/01/building-payment-microservice#webpage"},"wordCount":1383,"publisher":{"@id":"https://flexiana.com/#organization"},"image":{"@id":"https://flexiana.com/2020/01/building-payment-microservice#primaryimage"},"thumbnailUrl":"https://flexiana.com/app/uploads/2020/01/PPC_Flexiana_1-scaled.jpg","articleSection":["Case studies"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://flexiana.com/#/schema/person/94036a92c687499a03b07818de7bbe1d","name":"Pawel Zielonka","description":"Software architecture and design enthusiast, always willing to learn new technologies, help teammates and share knowledge.","url":"https://flexiana.com/author/pawel-zielonka"}]}</script>


<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//polyfill.io' />
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://flexiana.com/wp/wp-includes/css/dist/block-library/style.min.css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/4.5.1/css/bootstrap.min.css' media='all' />
<link rel='stylesheet' id='flexiana-app-css'  href='https://flexiana.com/app/themes/flexianacom/dist/assets/css/app.css?20210803&#038;ver=5.7.2' media='all' />
<link rel='stylesheet' id='noty-css'  href='https://cdnjs.cloudflare.com/ajax/libs/noty/3.1.4/noty.min.css' media='all' />
<link rel='stylesheet' id='swiper-css'  href='https://cdnjs.cloudflare.com/ajax/libs/Swiper/5.4.5/css/swiper.min.css' media='all' />
<link rel='stylesheet' id='cookieconsent-css'  href='https://cdnjs.cloudflare.com/ajax/libs/cookieconsent/3.1.1/cookieconsent.min.css' media='all' />
<link rel='stylesheet' id='prism-css'  href='https://cdnjs.cloudflare.com/ajax/libs/prism/1.21.0/themes/prism.min.css' media='all' />
<script src='https://flexiana.com/wp/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script src='https://flexiana.com/wp/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script src='https://cdnjs.cloudflare.com/ajax/libs/reading-time/2.0.0/readingTime.min.js' id='reading-time-js'></script>
<script src='https://cdnjs.cloudflare.com/ajax/libs/jquery.matchHeight/0.7.2/jquery.matchHeight-min.js' id='match-height-js'></script>
<script src='https://cdnjs.cloudflare.com/ajax/libs/noty/3.1.4/noty.min.js' id='noty-js'></script>
<script src='https://cdnjs.cloudflare.com/ajax/libs/prism/1.21.0/prism.min.js' id='prism-js'></script>
<script src='https://cdnjs.cloudflare.com/ajax/libs/prism/1.21.0/components/prism-markup.min.js' id='prism-markup-js'></script>
<script src='https://cdnjs.cloudflare.com/ajax/libs/prism/1.21.0/components/prism-clojure.min.js' id='prism-clojure-js'></script>
<script src='https://cdnjs.cloudflare.com/ajax/libs/prism/1.21.0/components/prism-json.min.js' id='prism-json-js'></script>
<script src='https://cdnjs.cloudflare.com/ajax/libs/prism/1.21.0/components/prism-haskell.min.js' id='prism-haskell-js'></script>
<script src='https://cdnjs.cloudflare.com/ajax/libs/prism/1.21.0/components/prism-ruby.min.js' id='prism-ruby-js'></script>
<link rel="https://api.w.org/" href="https://flexiana.com/wp-json/" /><link rel="alternate" type="application/json" href="https://flexiana.com/wp-json/wp/v2/posts/713" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://flexiana.com/wp/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://flexiana.com/wp/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://flexiana.com/?p=713' />
<link rel="alternate" type="application/json+oembed" href="https://flexiana.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fflexiana.com%2F2020%2F01%2Fbuilding-payment-microservice" />
<link rel="alternate" type="text/xml+oembed" href="https://flexiana.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fflexiana.com%2F2020%2F01%2Fbuilding-payment-microservice&#038;format=xml" />
<style>.post-thumbnail img[src$='.svg'] { width: 100%; height: auto; }</style>            </head>
<body class="post-template-default single single-post postid-713 single-format-standard">

	<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-P5PNM3N" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

			<header id="mainHeader">
    <div class="container">
        <nav class="navbar navbar-expand-lg">
    <a class="navbar-brand" href="https://flexiana.com">Flexiana</a>
    <button class="navbar-toggler collapsed" type="button" data-toggle="collapse" data-target="#navbarNav" aria-controls="navbarNav" aria-expanded="false" aria-label="Menu">
        <span class="icon-bar top-bar">top-bar</span>
        <span class="icon-bar middle-bar">middle-bar</span>
        <span class="icon-bar bottom-bar">bottom-bar</span>
        <span class="sr-only">Menu</span>
    </button>
    <div class="collapse navbar-collapse" id="navbarNav">
        <ul class="navbar-nav ml-auto">
                        <li class="nav-item">
                <a class="nav-link" href="https://flexiana.com/">Home</a>
                            </li>
                        <li class="nav-item dropdown">
                <a class="nav-link dropdown-toggle" href="#">Services</a>
                                <div class="dropdown-menu sm-menu">
                                        <a class="dropdown-item" href="https://flexiana.com/services/service-design">Service Design</a>
                                        <a class="dropdown-item" href="https://flexiana.com/services/software-development">Software Development</a>
                                        <a class="dropdown-item" href="https://flexiana.com/services/change-management">Change Management</a>
                                        <a class="dropdown-item" href="https://flexiana.com/services/digital-product-development">Product Development</a>
                                    </div>
                            </li>
                        <li class="nav-item">
                <a class="nav-link" href="https://flexiana.com/work">Work</a>
                            </li>
                        <li class="nav-item">
                <a class="nav-link" href="https://flexiana.com/news">News</a>
                            </li>
                        <li class="nav-item">
                <a class="nav-link" href="https://flexiana.com/about">About</a>
                            </li>
                        <li class="nav-item">
                <a class="nav-link" href="https://flexiana.com/jobs">Jobs</a>
                            </li>
                        <li class="nav-item">
                <a class="nav-link" href="https://flexiana.com/contact">Contact</a>
                            </li>
                    </ul>
    </div>
</nav>    </div>
</header>	
	
	<div class="breadcrumbs">
		<div class="container">
			<div class="breadcrumbs"><span><span><a href="https://flexiana.com/">Home</a> / <span><a href="https://flexiana.com/news">News</a> / <span><a href="https://flexiana.com/news/case-studies">Case studies</a> / <span class="breadcrumb_last" aria-current="page">Building Payment Microservice in Starcity</span></span></span></span></span></div>		</div>
	</div>

	<section class="page_header">
		<div class="container">
			<h1 class="post-title">Building Payment Microservice in Starcity</h1>
			<div class="meta">
				<span class="date">January 29, 2020</span>&nbsp;&bull;&nbsp;<span class="eta"></span> read
			</div>
		</div>
	</section>

	<article>
		<div class="container">
			
<blockquote class="wp-block-quote"><p>Starcity lacked capacities in his own development team. <strong>They needed to build a stable, complex application to manage their business processes that is ready for the fast growth of the company. Therefore the app had to be easy to extend and maintain for future development.</strong> One of the requirements was to automate the process of paying out funds from an external payment service to clients&#8217; bank accounts. Plus the code had to be friendly to the new programmers in the future. How have we done that?</p></blockquote>



<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="536" src="https://flexiana.com/app/uploads/2020/01/PPC_Flexiana_1-1024x536.jpg" alt="Screenshot of software development" class="wp-image-721" srcset="https://flexiana.com/app/uploads/2020/01/PPC_Flexiana_1-1024x536.jpg 1024w, https://flexiana.com/app/uploads/2020/01/PPC_Flexiana_1-300x157.jpg 300w, https://flexiana.com/app/uploads/2020/01/PPC_Flexiana_1-768x402.jpg 768w, https://flexiana.com/app/uploads/2020/01/PPC_Flexiana_1-1536x804.jpg 1536w, https://flexiana.com/app/uploads/2020/01/PPC_Flexiana_1-2048x1072.jpg 2048w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>



<p>Customer&#8217;s goal is to create opportunities for communities to live in one place. <strong>They deal with building and renting residential premises with shared kitchens, living rooms, laundry rooms and bathrooms. They create conditions for people to spend some time together.</strong></p>



<p>What the company needed, was stable application that manages business processes between clients, real estate management companies and customer&#8217;s team itself. They lacked development capacity in their own team. Another challenge was to make the application ready for the future growth of the company.</p>



<p>Therefore we had to develop an application that will be easy to extend and maintain in the future. So <strong>we separated a module for managing payments from the monolithic application and created a microservice to provide the opportunity for easier and faster development</strong>. The code is well documented to be friendly for new programmers in future. Also, we reduced some company costs by automating some processes.</p>



<h2>Project and application overview</h2>



<figure class="wp-block-image size-large"><img src="https://flexiana.com/app/uploads/2020/01/obrazek1.png" alt="Project and application overview" class="wp-image-714"/></figure>



<p>When we started, customer has had a monolithic application to manage business processes in the company. It contained several modules, each of which was responsible for different functionality. One of the requirements was to deal with processing payments between clients, real estate management companies and our customer.</p>



<p>The main types of payments were:</p>



<ul><li>monthly rental fees</li><li>subscription to &#8216;helping hands&#8217; service</li><li>deposits</li><li>refunds</li></ul>



<p>When we started, customer has had a monolithic application to manage business processes in the company. It contained several modules, each of which was responsible for different functionality. One of the requirements was to deal with processing payments between clients, real estate management companies and our customer.</p>



<p>Moreover, depending on the payment type and the rented building, <strong>the system had to handle an additional fee that was added and two ways of making deposits and withdrawals of funds</strong> i.e. bank transfers and card payments.</p>



<p>Because of the fact that the application was constantly growing, they created a library to separate implementation that contained:</p>



<ul><li>communication with external payment service</li><li>monitoring resources in the external service</li><li>processing bank transfers and card payments</li><li>managing subscriptions, properties and customers</li></ul>



<h2>Problems and client goals</h2>



<p>Despite the fact that the application had to meet the requirements of end customers, it also had to keep up with the development of the company, which was constantly growing. That is why <strong>one of the client&#8217;s goals was to automate the process of paying out funds from an external payment service to clients&#8217; bank accounts. Thanks to this, the company could dedicate human resources to other areas that would increase its profits and ensure faster growth.</strong></p>



<p>The development of the company goes hand in hand with the development of software, and this requires easy introduction of new functionality. For this to be possible, you need to constantly look after and improve the quality of the code. Our client was well aware of this, which is why it was another goal of our cooperation.</p>



<p>The last goal we faced was to separate the module for managing payments from the monolithic application and to create a microservice with which it could communicate.</p>



<h2>Solutions and our goals</h2>



<p>A team of five developers was appointed to work on the project: Eduardo from Brazil, Iain from Vietnam, Ondrej from the Czech Republic, Sergey from Russia and me from Poland. In addition, the client assigned two people from his side.</p>



<p><strong>The first step</strong> to provide the client with stable and easily extensible software<strong> was a profound analysis of existing implementation and understanding of the business domain.</strong> We had to know not only what requirements the business sets for us, but also what changes we can expect in the future. To achieve this, we organized r<strong>egular meetings with the team members on the client&#8217;s side who had been involved in creating the software from the beginning.</strong> This contributed to the continuous deepening of our knowledge about business, design, technologies and it made our domain knowledge good enough to provide a solid and well-tested code that solves customer’s problem.</p>



<p>As our knowledge about the project grew, we proceeded to separate the previously mentioned module into a microservice. We decided that the communication between the main application and the new service would take place via HTTP and we built a GraphQL API on top of that. Additionally, we had to identify entities that were associated with the module and place them in a new database available only for the newly created service.<br>Below you can see a simplified <strong>diagram of the entire system after the introduced changes</strong>:</p>



<figure class="wp-block-image size-large"><img src="https://flexiana.com/app/uploads/2020/01/obrazek2.png" alt="Project and application overview 2" class="wp-image-715"/></figure>



<p>Every month, people from the accounting department had to deal with cash withdrawals from an external payment service to bank accounts. The functionality of the external service was sufficient until the number of customers and withdrawals reached the level where more human resources were needed.</p>



<p><strong>To solve the problem of rising costs, we created a service that automated this process using the payment service API. It was monitoring transactions and checked which of them had to be paid out to customers.</strong> In order for everything to run successfully it was necessary to additionally monitor the balances of real estate accounts and supplement them with the appropriate amount of money in order not to reach a negative balance.</p>



<h2>Technology stack</h2>



<ul><li>Clojure &#8211; dynamic, general-purpose programming language (<a href="https://clojure.org">https://clojure.org</a>)</li><li>Datomic &#8211; distributed, functional database (<a href="https://www.datomic.com">https://www.datomic.com</a>)</li><li>Pedestal &#8211; set of libraries used for building services (<a href="http://pedestal.io">http://pedestal.io</a>)</li><li>Lacinia &#8211; Clojure library implementing GraphQL interface (<a href="https://github.com/walmartlabs/lacinia">https://github.com/walmartlabs/lacinia</a>)</li><li>Lacinia pedestal &#8211; library exposing lacinia as HTTP endpoints (<a href="https://github.com/walmartlabs/lacinia-pedestal">https://github.com/walmartlabs/lacinia-pedestal</a>)</li><li>Quartzite &#8211; scheduling library (<a href="http://clojurequartz.info">http://clojurequartz.info</a>)</li><li>Bond &#8211; spying and stubbing library used for testing (<a href="https://github.com/circleci/bond">https://github.com/circleci/bond</a>)</li><li>Cljfmt &#8211; tool library used for code formatting (<a href="https://github.com/weavejester/cljfmt">https://github.com/weavejester/cljfmt</a>)</li><li>Venia &#8211; Clojure/ClojureScript library to generate graphql queries (<a href="https://github.com/Vincit/venia">https://github.com/Vincit/venia</a>)</li><li>Reverse venia &#8211; Clojure library used for parsing GraphQL queries into Venia syntax (<a href="https://github.com/ondrs/reverse-venia">https://github.com/ondrs/reverse-venia</a>)</li></ul>



<h2>Work culture</h2>



<p>Our team works <strong>full time remotely</strong>. It is a very comfortable work style which implies physical and psychological comfort. Personally, it makes me more productive than when I work in the office. In addition, our team do not waste time on travelling to the workplace and can devote that time on relaxing or to additional work if necessary. It might seem to be difficult to organize a meeting when everybody has flexible working time, but each of us is aware of this. Therefore <strong>we plan the time in advance</strong> to perform our tasks and to attend important meetings with no difficulties.</p>



<p>We regularly organize meetings with programmers from other teams such as <strong>pair and team programming sessions</strong>, during which we solve problems, analyze application architecture, design new solutions, learn new technologies and get to know new tools that improve the quality of created software and accelerate its development. <strong>If I can speak in the name of the whole team, we enjoy sharing our experiences, ideas and suggestions about particular problems and solutions, because we believe that we can learn a lot from each other.</strong></p>



<h2>Conclusion</h2>



<p>We know that customer will be satisfied in the long term only if the product we are working on will be reliable, easy to extend and maintain. We know that by setting such requirements, we give our clients software that will reduce their costs.</p>



<p><strong>Our cooperation was successful &#8211; the same priorities translated into a good understanding between the teams and the pursuit of the same goals.</strong> Frequent meetings and discussions on the project and needs helped us develop the product very quickly. We took care of every detail of the implementation and wrote tests for our solutions. We documented the written code to minimize the time needed for its good understanding but also to be friendly for new programmers in the project.</p>

		</div>
	</article>

	
	<section class="author">
		<div class="container">
			<div class="author">
    <div class="row">
        <div class="col-md-2">
                        <div class="photo" style="background-image: url(https://flexiana.com/app/uploads/2020/01/photo-litewhat.jpg)"></div>
                    </div>
        <div class="col-md-10">
            <div class="name">
                <h4 class="name"><a href="https://flexiana.com/author/pawel-zielonka">Pawel Zielonka</a></h4>
            </div>
            <div class="description">Software architecture and design enthusiast, always willing to learn new technologies, help teammates and share knowledge.</div>
        </div>
    </div>
</div>
		</div>
	</section>

		<section class="mailchimp">
		<div class="container">
			<div class="col-md-8 offset-md-2">
				<h3>Read our next articles in your e-mail</h3>



<a name="form_1963213525"></a>
<form method="post" action="https://flexiana.com/2020/01/building-payment-microservice" name="form_1963213525" id="form_1963213525" data-parsley-validate="">
	<div class="row">
		<div class="col-lg-12 col-md-12">
			<p>Sign up to our newsletter</p>
		</div>
	</div>
	<div class="row">
		<div class="col-lg-8 col-md-8">
			<input
				type="email"
				name="form_1963213525_email"
				id="form_1963213525_email"
				value=""
				placeholder="* E-mail"
				class="form-control"
				required
				data-parsley-trigger="change"
			/>
		</div>
		<div class="col-lg-4 col-md-4">
			<input type="hidden" name="form_id" value="form_1963213525" />
			<input type="hidden" name="form_type" value="mailchimp" />
			<input type="hidden" name="form_1963213525_crsf" value="c61e7a13d6" />
			<input type="hidden" name="form_1963213525_recaptcha_response" id="form_1963213525_recaptcha_response" />
			<input type="submit" name="form_1963213525_submit" value="Subscribe" class="button" />
		</div>
	</div>
</form>
<script>;jQuery(function(){jQuery('#form_1963213525').parsley({errorClass:'is-invalid text-danger',successClass:'is-valid',errorsWrapper:'<span class="form-text text-danger"><\/span>',errorTemplate:'<span><\/span>',trigger:'change'}).on('field:validated',function(){}).on('form:submit',function(){});grecaptcha.ready(function(){grecaptcha.execute('6LcoArMUAAAAAAZYTsDipdVMLl6aiqx_F97icZZP',{action:'mailchimp'}).then(function(e){var a=document.getElementById('form_1963213525_recaptcha_response');a.value=e})})});</script>			</div>
		</div>
	</section>
	
	<script>jQuery(function(){jQuery('article').readingTime()})</script>

			<footer>
    <div class="container">
        <div class="row">
            <div class="col-lg-3 col-md-12">
                <img class="logo" src="https://flexiana.com/app/themes/flexianacom/dist/assets/images/logo_flexiana_gold.svg" alt="Logo Flexiana" />
                <ul class="contact">
                    <li><a href="mailto:hello@flexiana.com" title="hello@flexiana.com">hello<span>@flexiana.com</span></a></li>
                </ul>
                <a href="https://flexiana.com/2021/05/we-are-now-iso-27001-certified" title="We are now ISO 27001 Certified!"><img class="iso27001" src="https://flexiana.com/app/themes/flexianacom/dist/assets/images/iso27001.png" alt="ISO 27001" width="60" /></a>
            </div>
            <div class="col-lg-9 col-md-12">
                <div class="row">
                                        <div class="col-lg-3 col-md-6">
                        <ul class="footer_menu">
                                                        <li><a href="https://flexiana.com/work">Work</a></li>
                                                        <li><a href="https://flexiana.com/news">News</a></li>
                                                        <li><a href="https://flexiana.com/about">About</a></li>
                                                        <li><a href="https://flexiana.com/jobs">Jobs</a></li>
                                                    </ul>
                    </div>
                                        <div class="col-lg-3 col-md-6">
                        <ul class="footer_menu">
                                                        <li><a href="https://flexiana.com/contact">Contact</a></li>
                                                    </ul>
                    </div>
                                        <div class="col-lg-5 offset-lg-1 col-md-12">
                        <div class="mailchimp">
                            


<a name="form_1381935526"></a>
<form method="post" action="https://flexiana.com/2020/01/building-payment-microservice" name="form_1381935526" id="form_1381935526" data-parsley-validate="">
	<div class="row">
		<div class="col-lg-12 col-md-12">
			<p>Sign up to our newsletter</p>
		</div>
	</div>
	<div class="row">
		<div class="col-lg-8 col-md-8">
			<input
				type="email"
				name="form_1381935526_email"
				id="form_1381935526_email"
				value=""
				placeholder="* E-mail"
				class="form-control"
				required
				data-parsley-trigger="change"
			/>
		</div>
		<div class="col-lg-4 col-md-4">
			<input type="hidden" name="form_id" value="form_1381935526" />
			<input type="hidden" name="form_type" value="mailchimp" />
			<input type="hidden" name="form_1381935526_crsf" value="b832531ddb" />
			<input type="hidden" name="form_1381935526_recaptcha_response" id="form_1381935526_recaptcha_response" />
			<input type="submit" name="form_1381935526_submit" value="Subscribe" class="button" />
		</div>
	</div>
</form>
<script>;jQuery(function(){jQuery('#form_1381935526').parsley({errorClass:'is-invalid text-danger',successClass:'is-valid',errorsWrapper:'<span class="form-text text-danger"><\/span>',errorTemplate:'<span><\/span>',trigger:'change'}).on('field:validated',function(){}).on('form:submit',function(){});grecaptcha.ready(function(){grecaptcha.execute('6LcoArMUAAAAAAZYTsDipdVMLl6aiqx_F97icZZP',{action:'mailchimp'}).then(function(e){var a=document.getElementById('form_1381935526_recaptcha_response');a.value=e})})});</script>                        </div>
                    </div>
                </div>
            </div>
        </div>
        <div class="row">
            <div class="col-lg-4">
                <ul class="cities">
                                        <li>Sheridan</li>
                                        <li>London</li>
                                        <li>Prague</li>
                                        <li>Valencia</li>
                                        <li>Cairo</li>
                                        <li>Berlin</li>
                                        <li>Brno</li>
                                        <li>Warsaw</li>
                                    </ul>
            </div>
            <div class="col-lg-8">
                <ul class="social">
                                        <li><a href="https://www.linkedin.com/company/flexiana/" target="_blank"><img src="https://flexiana.com/app/uploads/2020/07/icon-linkedin.svg" alt="LinkedIn icon" /></a></li>
                                        <li><a href="https://twitter.com/flexiana" target="_blank"><img src="https://flexiana.com/app/uploads/2020/07/icon-twitter.svg" alt="Twitter icon" /></a></li>
                                        <li><a href="https://www.facebook.com/FlexianaDevGroup/" target="_blank"><img src="https://flexiana.com/app/uploads/2020/07/icon-facebook.svg" alt="Facebook icon" /></a></li>
                                        <li><a href="https://www.instagram.com/flexiana.team/" target="_blank"><img src="https://flexiana.com/app/uploads/2020/07/icon-instagram.svg" alt="Instagram icon" /></a></li>
                                        <li><a href="https://www.youtube.com/channel/UCg61aY2i6xcJl0KVNqX51Dg" target="_blank"><img src="https://flexiana.com/app/uploads/2020/07/icon-youtube.svg" alt="Youtube icon" /></a></li>
                                    </ul>
            </div>
        </div>
        <div class="row">
            <div class="col-lg-12">
                <ul class="footer_bottom_menu">
                                        <li><a href="https://flexiana.com/privacy-policy">Privacy Policy</a></li>
                                        <li><a href="https://flexiana.com/cookies-policy">Cookies Policy</a></li>
                                    </ul>
            </div>
        </div>
    </div>
</footer>
                        <div class="modal fade" id="lightbox-email" data-backdrop="static" data-keyboard="false" tabindex="-1" role="dialog" aria-labelledby="staticBackdropLabel" aria-hidden="true">
    <div class="modal-dialog modal-dialog-centered modal-lg">
        <div class="modal-content">
            <button class="close" onclick="dismissLightboxEmail()">X</button>
            <div class="in">
                <h3>Be in touch with us</h3>
                


<form method="post" action="https://flexiana.com/2020/01/building-payment-microservice" name="form_252174275" id="form_252174275" data-parsley-validate="">
	<div class="row">
		<div class="col-lg-8 col-md-8">
			<input
				type="email"
				name="form_252174275_email"
				id="form_252174275_email"
				value=""
				placeholder="* E-mail"
				class="form-control"
				required
				data-parsley-trigger="change"
			/>
		</div>
		<div class="col-lg-4 col-md-4">
			<input type="hidden" name="form_id" value="form_252174275" />
			<input type="hidden" name="form_type" value="mailchimp_lightbox" />
			<input type="hidden" name="form_252174275_crsf" value="3d0e4bfd18" />
			<input type="hidden" name="form_252174275_recaptcha_response" id="form_252174275_recaptcha_response" />
			<input type="submit" name="form_252174275_submit" value="Subscribe" class="button secondary" />
		</div>
	</div>
</form>
<script>;jQuery(function(){jQuery('#form_252174275').parsley({errorClass:'is-invalid text-danger',successClass:'is-valid',errorsWrapper:'<span class="form-text text-danger"><\/span>',errorTemplate:'<span><\/span>',trigger:'change'}).on('field:validated',function(){}).on('form:submit',function(){});grecaptcha.ready(function(){grecaptcha.execute('6LcoArMUAAAAAAZYTsDipdVMLl6aiqx_F97icZZP',{action:'mailchimp_lightbox'}).then(function(e){var a=document.getElementById('form_252174275_recaptcha_response');a.value=e})})});</script>                <p>You can unsubscribe at any time by clicking the link in the footer of our emails. For more information visit our <a href="/privacy-policy" target="_blank">Privacy policy</a>.</p>
                <p>We use Mailchimp as our marketing platform. By clicking below to subscribe, you acknowledge that your information will be transferred to Mailchimp for processing. Learn more about <a href="https://mailchimp.com/legal/" target="_blank">Mailchimp's privacy practices</a>.</p>
            </div>
        </div>
    </div>
</div>
<script>;jQuery(function(){var e=getCookie('flexiana_lightboxemail');if(!e){setTimeout(function(){jQuery('#lightbox-email').modal();chatToggle()},30*1000)}});</script>            		<script src='https://flexiana.com/app/themes/flexianacom/dist/assets/js/app.js?20210803&#038;ver=5.7.2' id='flexiana-app-js'></script>
<script src='https://www.google.com/recaptcha/api.js?render=6LcoArMUAAAAAAZYTsDipdVMLl6aiqx_F97icZZP&#038;ver=5.7.2' id='recaptcha-js'></script>
<script src='https://cdnjs.cloudflare.com/ajax/libs/instant.page/5.1.0/instantpage.min.js' id='instantpage-js'></script>
<script src='https://cdnjs.cloudflare.com/ajax/libs/parsley.js/2.9.2/parsley.min.js' id='parsley-js'></script>
<script src='https://cdnjs.cloudflare.com/ajax/libs/Swiper/5.4.5/js/swiper.min.js' id='swiper-js'></script>
<script src='https://cdnjs.cloudflare.com/ajax/libs/cookieconsent/3.1.1/cookieconsent.min.js' id='cookieconsent-js'></script>
<script src='https://cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/4.5.1/js/bootstrap.min.js' id='bootstrap-js'></script>
<script src='https://polyfill.io/v3/polyfill.min.js?features=es6&#038;ver=5.7.2' id='polyfill-js'></script>
<script src='https://cdn.jsdelivr.net/npm/mathjax@3/es5/tex-mml-chtml.js' id='mathjax-js'></script>
<script src='https://flexiana.com/wp/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>

	
	
</body>
</html>